cci背离指标公式源码

股票学习网 发布:2019-08-16 17:21:00 阅读:226次
  1. cci背离指标公式1,cci穿过-100,并且趋势变红色,底部买点2,面织背离是我自己加上去的,面积底背是指cci在0轴下方的面织也前一个在0轴下方的面积的对比,顶背也是这道理

cci背离指标公式源码

3,所有背离信号只能作参考!

4,指标非本人原创,根据论坛甘大神的改编哦……

{背景}

DRAWutf-8(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);

STICKLINE(C>0,-100,100,28,0)COLOR000840;

STICKLINE(C>0,200,200,28,-1)COLOR000080;

STICKLINE(C>0,100,100,28,-1)COLOR000080;

STICKLINE(C>0,-2.5,2.5,28,0)COLOR000080;

STICKLINE(C>0,-100,-100,28,-1)COLOR000080;

STICKLINE(C>0,-200,-200,28,-1)COLOR000080;

{ cci背离指标公式}

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),STICK;{CCI柱线}

趋势线:EXPMA(CCI,4.5),COLORFF8000,NODRAW;{CCI的5天EMA}

DRAWBAND(CCI,RGB(128,0,0),趋势线,RGB(0,128,0));

STICKLINE(CCI>=0,0,CCI,0,-1),COLORLIRED;{红柱}

STICKLINE(CCI<0,0,CCI,0,-1),COLORLIBLUE;{绿柱}

{CCI}

{TYP:=(HIGH+LOW+CLOSE)/3;}

CCI值:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORYELLOW,LINETHICK1;{CCI线}

DRAWTEXT(ISLASTBAR,CCI值,' ←CCI'),COLORYELLOW;

{CCI背离}

N:=5;

CCI底背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),1))+1)>C AND

REF(CCI,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),1))+1)<CCI AND

FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),COLORWHITE,NODRAW;

DRAWLINE(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),CCI,FILTER(CCI底背>0,5),CCI,0),

COLORWHITE,DOTLINE;

DRAWTEXT(CCI底背,CCI,'底背'),COLORWHITE;

CCI顶背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),1))+1)<C AND

REF(CCI,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),1))+1)>CCI AND

FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),COLORGREEN,NODRAW;

DRAWLINE(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),CCI,FILTER(CCI顶背>0,5),CCI,0),

COLORGREEN,DOTLINE;

DRAWTEXT(CCI顶背,CCI,'顶背'),COLORGREEN;

{趋势线的背离}

趋势线底背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),1))+1)>C AND

REF(趋势线,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),1))+1)<趋势线 AND

FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),COLORWHITE,NODRAW;

DRAWLINE(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),趋势线,FILTER(趋势线底背>0,5),趋势线,0),

COLORWHITE,DOTLINE;

DRAWTEXT(趋势线底背,趋势线,'趋势底背'),COLORFF80FF;

趋势线顶背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),1))+1)<C AND

REF(趋势线,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),1))+1)>趋势线 AND

FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),COLORGREEN,NODRAW;

DRAWLINE(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),趋势线,FILTER(趋势线顶背>0,5),趋势线,0),

COLORGREEN,DOTLINE;

DRAWTEXT(趋势线顶背,趋势线,'趋势顶背'),COLORFF8000;

{面积背离}

JC:= 0-CCI;

绿柱面积:=IF(CCI<0,SUM(CCI,BARSLAST(JC<0)),0);

红柱面积:=IF(CCI>0,SUM(CCI,BARSLAST(JC>0)),0);

本次最低价:=LLV(L,BARSLAST(JC<0));

本次最高价:=HHV(H,BARSLAST(JC>0));

X1:=IF (CCI<0,BARSLAST(CROSS(CCI,0)),0);

前次绿柱面积:=REF(绿柱面积,X1+1);

前次最低价:=REF(本次最低价,X1+1);

Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);

RS1:= CCI<0 AND REF(CCI,1)<0 AND C<前次最低价

AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(CCI)<ABS(REF(CCI,1));

底背驰:= IF (CROSS(CCI,0),REF(Y1,1),0);

DRAWTEXT(底背驰,LLV(CCI,5),'←面积底背'),COLORLIRED;

X2:=IF (CCI>0,BARSLAST(CROSS(0,CCI)),0);

前次红柱面积:=REF(红柱面积,X2+1);

前次最高价:=REF(本次最高价,X2+1);

Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);

RS2:= CCI>0 AND REF(CCI,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(CCI)<ABS(REF(CCI,1));

顶背驰:= IF (CROSS(0,CCI),REF(Y2,1),0);

DRAWTEXT(顶背驰,HHV(CCI,5),'←面积顶背'),COLORCYAN;

cci背离指标公式源码所属专题: cci专题   本文《cci背离指标公式源码》链接:http://www.mingjia56.net/1519/

cci背离指标公式源码相关文章

cci背离指标公式源码图解
  • boll和macd黄金组合:黄金抄底组合,KDJ+CCI+MACD+BOLL
  • cci指标日周月共振:优化CCI指标,使之信号更加精准无比
  • 股票短线指标哪个靠谱:CCI,看懂CCI指标次次买在最低点
  • dmi指标参数3 2:CCI+DMI+薛斯通道+薛斯通道II
  • 股票cci指标参数设置:怎样设置股票CCI指标是最合理的?
  • cci股票:一旦股票出现“CCI”洗盘形态,股价直线拉升
  • 5分钟cci指标和30分钟CCI指标买入法
  • 股票指标cci看日线还是周线:沪指成功收复年线实现日线五连阳
  • 解析cci选股法
  • CCI是什么意思
  • 揭露股票cci指标使用技巧
  • cci背离短线王的高级用法
  • 股票技术指标cci视频:CCI指标参数84发现强势股票实战应用底背离买点
  • 解密同花顺CCI指标在哪
  • 期货cci参数设置:程序化研究之结合CCI的均线策略
  • 股票中cci代表什么:第二日涨停的股票,“CCI”必定有这特征
  • CCI怎么看怎么设置
  • CCI指标怎么操作
  • cci指标如何看:炒股别忘了看一眼CCI指标,精准判断买卖点,看懂等于成功了一半!
  • 周线cci和kDJ:退役老股民讲解的MACD结合KDJ和CCI运用,让散户看了在看!
  • cci指标参数34:老股神曝光CCI指标之谜,庄家看完都直冒冷汗
  • 股票技术指标cci:的实战应用
  • cci超买超卖:一脚定江山操盘秘籍
  • cci底背离选股公式源码图解
  • cci指标详解附图:CCI指标精髓战法精讲,看懂跟着庄家一起吃肉
  • 短线cci指标设置44参数短线最好吗?
  • 选股时经常听到的cci是什么意思
  • 股票cci秘诀招式有哪些
  • 股市高手解析cci是什么指标
  • cci负200:KDJ+CCI+MACD+BOLL,超精准抄底逃顶
  • cci指标炒股绝招有哪些
  • cci炒股绝技:炒股巧用“CCI”指标,散户也能把庄家耍的团团转,牢记足矣!
  • cci30分钟战法:CCI指标买卖点终极战法
  • CCi与kDJ比较:史上最经典KDJ和CCI的使用法与几种常见的图形
  • cci指标计算公式:cci指标详解图解,CCI指标的计算公式是什么?
  • 股市cci怎么用:一位股市天才不传的CCI运用精髓
  • 日内短线看什么指标:庄家最怕的短线买卖“指标之王”——CCI指标,十拿九稳
  • 看盘技巧
  • 跟庄技巧
  • 炒股技巧
  • 选股技巧
  • 炒股经验
  • 盘口技巧
  • 买入技巧
  • 卖出技巧
  • 短线技巧
  • 做T技巧
  • 止损技巧
  • 止盈技巧
  • 追涨技巧
  • 涨停技巧
  • 补仓技巧
  • 加仓技巧
  • 抄底技巧
  • 逃顶技巧
  • 打板技巧
  • 实战技巧
  • 实盘技巧
  • 操盘技巧
  • 抓板技巧
  • 挖牛股技巧
  • 基本面分析
  • 投资策略
  • 波段操作
  • 黑马捕捉
  • 解套方法
  • 趋势分析
  • 回顶部